Home » Developer & Programmer » Forms » Doesn't show lov for single record... (Oracle 9i Forms)
Doesn't show lov for single record... [message #323564] Wed, 28 May 2008 19:07 Go to next message
urnikhil
Messages: 42
Registered: March 2008
Member
Hi,

I created a LOV and assigned it to a text item. Then I created a when-mouse-click trigger in which I used SHOW_LOV built-in to display the LOV (I have to do like this because of business requirements).

Know my LOV displays list of values when it retrieves more than one record. Whereas if it has a single record, it doesn't show anything when I click on the text item. Neither it shows any error.

Any help in this regard would be greatly appreciated.

Nik.
Re: Doesn't show lov for single record... [message #323607 is a reply to message #323564] Thu, 29 May 2008 00:16 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:
if it has a single record, it doesn't show anything
Can you verify that SELECT statement, in this case, REALLY returns one record? What if there's no record at all?
Re: Doesn't show lov for single record... [message #323811 is a reply to message #323607] Thu, 29 May 2008 10:10 Go to previous messageGo to next message
urnikhil
Messages: 42
Registered: March 2008
Member
Hey Littlefoot,

Thanks for your concern on this issue. I found work around for this.

In my LOV properties, I set "Automatic Select" to "YES" which automatically maps the value to the text item when the LOV is reduced to single choice. Whereas in my case, I didn't specify any mapping properties for the LOV. So that's the issue.

Anyways thanks for this forum.

Nik.
Re: Doesn't show lov for single record... [message #323846 is a reply to message #323811] Thu, 29 May 2008 13:22 Go to previous message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Thank you for the feedback!
Previous Topic: Reverse engineering an Oracle Form
Next Topic: Run time Menu attachment in D2K
Goto Forum:
  


Current Time: Fri Dec 02 23:21:54 CST 2016

Total time taken to generate the page: 0.08267 seconds