Home » Server Options » Streams & AQ » Schema replication doesn't work (Oracle 10g R2 (10.2.0.4) on Windows XP SP2)
Schema replication doesn't work [message #321695] Wed, 21 May 2008 01:34 Go to next message
ahmedb72
Messages: 5
Registered: May 2007
Location: UAE
Junior Member

Hi all,

I configured bi-directional schema-level replication between two databases db1 (the source) and db2 (the destination) on HR schema using DBMS_STREAMS_ADM.MAINTAIN_SCHEMAS schema. When I started the configuration, HR schema was there in db1 but not in db2.

After the procedure was succesffully executed, I noticed the HR schema created in db2 but with no objects inside it.

What could be the reason? Is it because the INCLUDE_DDL parameter was set to FALSE.

Any guide is appreciated.

Below is the code:



DBMS_STREAMS_ADM.MAINTAIN_SCHEMAS(
SCHEMA_NAMES => 'hr',
SOURCE_DIRECTORY_OBJECT => 'strmadir',
DESTINATION_DIRECTORY_OBJECT => 'strmadir',
SOURCE_DATABASE => 'db1',
DESTINATION_DATABASE => 'db2',
PERFORM_ACTIONS => true,
BI_DIRECTIONAL => true,
INCLUDE_DDL => false);
end;
Re: Schema replication doesn't work [message #323190 is a reply to message #321695] Tue, 27 May 2008 11:24 Go to previous message
sonumalhi
Messages: 62
Registered: April 2008
Member
Can you please send the whole script you used to implement streams.
Prob you are missing something.
Previous Topic: How to handle UPDATE dml opration in add_subset_rule(Oracle Streams) (merged)
Next Topic: MQ series connectivity to Oracle
Goto Forum:
  


Current Time: Wed Apr 16 18:10:14 CDT 2014

Total time taken to generate the page: 0.09195 seconds