Home » Developer & Programmer » Forms » Problem with window size (Forms 6i, Linux Ellopac 2.0, HP-UX 11)
Problem with window size [message #320576] Thu, 15 May 2008 09:25 Go to next message
MissElectra
Messages: 17
Registered: May 2008
Junior Member
Hi experts,

After the migration of our application from Forms 4.5 to Forms 6i, some windows don't have the height that we specify in Forms Designer and the windows are truncated. The problem is not systematic: sometimes the windows have the correct size and sometimes not. Do you have an idea about the cause of this problem?

We try to set the window's size in the program, using the command "resize_window" or "SET_WINDOW_PROPERTY('FENETRE1',WINDOW_STATE,MAXIMIZE)", and we use the command SYNCHRONIZE and SHOW_VIEW, but the problem always exists.

Our application works on Client/server environnement with OS HP or OS Linux, not in web environnement.

Thanks for your help.
Re: Problem with window size [message #320682 is a reply to message #320576] Thu, 15 May 2008 18:47 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You need to use the 'forms_mdi_window' as in "Set_Window_Property(FORMS_MDI_WINDOW, WINDOW_STATE, MINIMIZE)".

Also look at http://www.orafaq.com/wiki/Forms_FAQ

David

[Updated on: Thu, 15 May 2008 18:51]

Report message to a moderator

Re: Problem with window size [message #320797 is a reply to message #320682] Fri, 16 May 2008 04:54 Go to previous messageGo to next message
MissElectra
Messages: 17
Registered: May 2008
Junior Member
We set the instruction "SET_WINDOW_PROPERTY(FORMS_MDI_WINDOW,WINDOW_STATE,MAXIMIZE)" in the trigger When-New-Form-Instance but it doesn't work.
The problem exists on Linux but not in HP. Could it be a problem in the environnement of Forms execution?

[Updated on: Fri, 16 May 2008 09:26]

Report message to a moderator

Re: Problem with window size [message #321308 is a reply to message #320797] Mon, 19 May 2008 19:45 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Is Linux and HP your server OS or your user OS?

Are you running Client-Server or 3-tier?

I suggest that you try the following and see if it changes the behaviour. Place a 'pause' command after the 'Set_Window_Property' command and maybe a 'synchronize' command as well before the 'pause'. Perhaps you have another command further down the stream of commands which is overriding the 'maximise', for example, a window_hide / window_show and the 'pause' will let you see whether the command is working AT THAT TIME but is being reset by something later.

David
Re: Problem with window size [message #323395 is a reply to message #321308] Wed, 28 May 2008 06:50 Go to previous messageGo to next message
MissElectra
Messages: 17
Registered: May 2008
Junior Member
our server is on Linux and our client may be on Linux or HP. I think we are running Client-Server. I don't know 3-tier.

I try your suggestion. With 'pause' command, I hadn't the problem after many tests. The 'pause' command seems to stop the problem from happening.

Is it possible that the window manager (we use mwm) is occasionally so fast that it create the mwm window before the canvas is displayed and it don't have the real size of the canvas? It will explain what the problem is not systematic.

Sandrine.
Re: Problem with window size [message #335323 is a reply to message #323395] Mon, 21 July 2008 20:09 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I don't know 'mwm'.

Replace some of the 'pause' commands with 'synchronize'. This will help 'slow' things down if speed is the actual problem.

David
Previous Topic: Timer Problem
Next Topic: Forms 10 G Error 10142
Goto Forum:
  


Current Time: Sun Dec 04 16:43:30 CST 2016

Total time taken to generate the page: 0.06521 seconds