Home » Developer & Programmer » Reports & Discoverer » old version of PDF exported from report builder (Report Builder 6.0.8.12.1, windows XP)
old version of PDF exported from report builder [message #316165] Thu, 24 April 2008 00:51 Go to next message
cardel
Messages: 21
Registered: April 2008
Junior Member
I have Report Builder 6.0.8.12.1
When I choose File - Generate to file - PDF in report preview I'll get pdf but this file is in very old pdf version. Only in 1.1. I found that the file was generated by Oracle PDF Driver, because it is in properties of pdf file (screenshot is in attachements).
Is there any way to export my reports to newer pdf version? I searched this forum and someone advice to install newer Adobe Acrobat Reader. I tried, but with no effect.

And I have another problem with export. Some CZECH symbols are showed improperly.

Any ideas to solve my problems?

Thanks

./fa/4183/0/
Re: old version of PDF exported from report builder [message #316172 is a reply to message #316165] Thu, 24 April 2008 01:50 Go to previous messageGo to next message
Littlefoot
Messages: 20895
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
PDF Version 1.1? What does it matter, anyway? Which version would make you happy? (As an illustration, Reports Builder 10g creates PDFs using version 1.4 (Acrobat 5.x), so what?)

As of improper character display: did you install Adobe Reader CE (Central European edition)? If not, try to do so and see what happens.
Re: old version of PDF exported from report builder [message #316195 is a reply to message #316172] Thu, 24 April 2008 03:56 Go to previous messageGo to next message
cardel
Messages: 21
Registered: April 2008
Junior Member
Yes I tried Acrobat Reader 8.0 CE and 7.0 CE with no effect on version of generated PDF or on improperly showed characters.
I would like newer version of PDF because I need to implement "electronic sign" to it.
Characters adn version of PDF is excelent when I use PDFCreator for printing reports, but I would like to export reports without need another software.

Re: old version of PDF exported from report builder [message #316216 is a reply to message #316195] Thu, 24 April 2008 05:21 Go to previous messageGo to next message
Littlefoot
Messages: 20895
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I see ... well, as far as I can tell, Reports version 6i uses internal PDF driver version 1.1; 9i and 10g use 1.4.

As PDF driver can not be obtained separately, you'll either have to migrate your reports to a higher version, or use another piece of software (PDF Creator, as you say).

Perhaps there is a workaround, but I don't know it.
Re: old version of PDF exported from report builder [message #317112 is a reply to message #316216] Tue, 29 April 2008 10:16 Go to previous messageGo to next message
cardel
Messages: 21
Registered: April 2008
Junior Member
I tried PDFCreator, but with no results. When I send report direct to PDFCreator printer with RUN_PRODUCT the background report job starts formatting report and sending it to printer. But background job of report builder mostly fails before or during PDF conversion. Some report is converted without problems, some reports mostly reports with more pages caused problems.
Do you know about some free pdf software which install own printer and can be configurated to autosaving pdf? I need convert pdf automatically without confirmation by user.

Re: old version of PDF exported from report builder [message #317146 is a reply to message #317112] Tue, 29 April 2008 12:33 Go to previous message
Littlefoot
Messages: 20895
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I use PrimoPDF, but user has to perform several mouse clicks.
Previous Topic: Multi-Org Access Control issue in Discoverer
Next Topic: Report to Excel (RPT2XLS)
Goto Forum:
  


Current Time: Mon Dec 05 21:04:21 CST 2016

Total time taken to generate the page: 0.10115 seconds