Home » RDBMS Server » Backup & Recovery » RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g (DB 10g solaris; RMAN catalog 10g LINUX)
RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315272] Sun, 20 April 2008 13:30 Go to next message
geeklol
Messages: 59
Registered: March 2005
Member
i have a db which was upgraded yesterday from 9i to 10g.

i used to backup the 9i db using this catalog fine.
but now that it is upgraded to 10g, i get a resync error while backing it up the same 10g catalog;

i tried to unregister and register the db but still the same error,

PLEASE HELP, THIS IS A HIGH PROFILE PRODUCTION DB FOR MY COMPANY AND IT HAS TO BACKUP TONIGHT.

connected to recovery catalog database

RMAN> reset database;

starting full resync of recovery catalog
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of reset command at 04/20/2008 11:11:20
RMAN-03014: implicit resync of recovery catalog failed
RMAN-03009: failure of full resync command on default channel at 04/20/2008 11:11:20
ORA-01400: cannot insert NULL into ("RMAN"."BSF"."MODIFICATION_TIME")

RMAN> unregister database;

database name is "LCECDB" and DBID is 4003965447

Do you really want to unregister the database (enter YES or NO)? yes
database unregistered from the recovery catalog

RMAN> register database;

database registered in recovery catalog
starting full resync of recovery catalog
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03008: error while performing automatic resync of recovery catalog
ORA-01400: cannot insert NULL into ("RMAN"."BSF"."MODIFICATION_TIME")

-tHANK YOU.

Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315273 is a reply to message #315272] Sun, 20 April 2008 13:40 Go to previous messageGo to next message
Michel Cadot
Messages: 64133
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You didn't upgrade the catalog.
You didn't 10g RMAN.

Regards
Michel
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315275 is a reply to message #315272] Sun, 20 April 2008 14:05 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Hi Michel,

THE CATALOG IS ALREADY AND ALWAYS HAS BEEN 10g.
WE WERE BACKING UP 9i DB TO 10g CATALOG AND NOW THE DB HAS BEEN UPGRADED FROM 9I TO 10G.


SQL> select * from v$instance;

INSTANCE_NUMBER INSTANCE_NAME
--------------- ----------------
HOST_NAME
----------------------------------------------------------------
VERSION STARTUP_T STATUS PAR THREAD# ARCHIVE LOG_SWITCH_WAIT
----------------- --------- ------------ --- ---------- ------- ---------------
LOGINS SHU DATABASE_STATUS INSTANCE_ROLE ACTIVE_ST BLO
---------- --- ----------------- ------------------ --------- ---
1 rcatg
laxas4bkp01
10.2.0.1.0 19-APR-08 OPEN NO 1 STOPPED
ALLOWED NO ACTIVE PRIMARY_INSTANCE NORMAL NO
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315278 is a reply to message #315275] Sun, 20 April 2008 14:21 Go to previous messageGo to next message
Michel Cadot
Messages: 64133
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I don't answer to post in UPPER CASE and that is not formatted.
Read and follow OraFAQ Forum Guide

Regards
Michel
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315280 is a reply to message #315275] Sun, 20 April 2008 14:47 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Hi Michel,

I really appreciate your help with this!

Answering your question about, if i have upgraded my catalog from 9i to 10g,

The rman catalog is 10g.

Before the upgrade of the database, i was backing up 9i database to a 10g catalog. So the catalog already has this database's information in its repository.

Now that i have upgraded the database from 9i to 10g (while the catalog stays the same, 10g), i am getting the resyncing error backing up the 10g database to a 10g catalog.

Thank you!
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315287 is a reply to message #315280] Sun, 20 April 2008 16:29 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Try to execute the following:

SQL> execute dbms_backup_restore.resetCfileSection(21);
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315288 is a reply to message #315272] Sun, 20 April 2008 19:29 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
The following command seemed to work and now i am able to register the target database in the catalog:
SQL> execute dbms_backup_restore.resetCfileSection(21);

Now when i try to run the backup,
<we are using Veritas Netbackup>
it errors out saying,
We know that the MML is available.
The question is, after we upgraded the target database from 9i to 10g, do we have to reinstall and re-configure the netbackup agent on this host?

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on K00S channel at 04/20/2008 17:17:54
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
Additional information: 2

thank you!
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315290 is a reply to message #315288] Sun, 20 April 2008 20:22 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
geeklol wrote on Sun, 20 April 2008 20:29

The question is, after we upgraded the target database from 9i to 10g, do we have to reinstall and re-configure the netbackup agent on this host?

Yes. You should re-link NetBackup with Oracle.
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315293 is a reply to message #315272] Sun, 20 April 2008 21:52 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Do i need to shutdown and restart the database in order to re-link?

I can't shutdown this database. it is our production db and the next maintenance window is next sunday.

Any workarounds, if i have to shudown the database?
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315368 is a reply to message #315293] Mon, 21 April 2008 05:30 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Netbackup install instructions will tell you to stop all databases running in the Oracle home you need to link. However, I don't know what version of Netbackup you are using, but for version 4.5 and newer, you should not have to shutdown the database to relink. To be on the safe side, you could lsof | grep libobk.so and see if the file is in use.
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315515 is a reply to message #315272] Mon, 21 April 2008 16:05 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
backup to a netapps mount point using RMAN?

Since management doesn't feel comfortable relinking the db for the netbackups to work, we are looking at a workaround until our next maintenance window.

So what we have decided to do now, is to do a HOT, full backup of the db using RMAN with catalog or no catalog (what should i do? should i use the catalog, can i use the catalog?) and back it up to a netapps mount point.

all my datafiles are on /db02 and control files, redo logs etc are on /redo and /redo2; i want RMAN to backup to /lcecdb10g_bkp

oracle@laxs90db01: df -kh
Filesystem size used avail capacity Mounted on
/dev/dsk/emcpower5a 483G 336G 142G 71% /db02
/dev/dsk/emcpower0a 65G 9.9G 54G 16% /redo
/dev/dsk/emcpower4a 66G 9.7G 55G 16% /redo2
laxfas92002:/vol/lcecdb9i_bkp
400G 1.4M 400G 1% /lcecdb10g_bkp


My RMAN script currently looks like as follows and is being run by a shell script which sets the environment variables etc.
What changes do i need to make to the script, so it knows to backup to /lcecdb10g_bkup mount point vs assigning a channel?


#der: lcecdb_backup_level0.rcv,v 1.5 2004/10/21 21:40:06 integ Exp $
# ---------------------------------------------------------------------------
# lcecdb_backup_level0.rcv
# ---------------------------------------------------------------------------
# Script run by:
# rman nocatalog cmdfile lcecdb_backup_level0.rcv
# ---------------------------------------------------------------------------

connect target
connect catalog rman/rman@rcatg

set snapshot controlfile name to '/home/archive/DBA/backup_to_tape/48009/snapcf_lcecdb.f'

run {
# Hot database level 0 whole backup
allocate channel t1 type 'SBT_TAPE';
backup
incremental level 0
skip inaccessible
# recommended format
format 'bk_%s_%p_%t'
database
filesperset = 500;
sql 'alter system archive log current';
release channel t1;

allocate channel t1 type 'SBT_TAPE';
backup
format 'cntrl_%s_%p_%t'
current controlfile;
release channel t1;
}
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #315533 is a reply to message #315515] Mon, 21 April 2008 19:18 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You can still use the catalog and modify you backup script as follows:

run {
# Hot database level 0 whole backup
allocate channel t1 type disk;
backup
incremental level 0
skip inaccessible
# recommended format
format '/lcecdb10g_bkup/bk_%s_%p_%t'
database
filesperset = 500;
sql 'alter system archive log current';

backup
archivelog all
format '/lcecdb10g_bkup/arc_%s_%p_%t';

backup
format '/lcecdb10g_bkup/cntrl_%s_%p_%t'
current controlfile;
release channel t1;
}

You should also include archive logs which I included above.

For future posts, please use code tags [code] [/code] for formatting.

[Updated on: Mon, 21 April 2008 19:23]

Report message to a moderator

Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #316083 is a reply to message #315272] Wed, 23 April 2008 13:00 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Thank you ebrian for all your help. It has been a life saver!!! May thanks for a mid-level DBA.

I have another database, which has always been 10g and now i am trying to back it up using the new catalog. It is registered in the catalog. But when i try to back it up, it give me the following error. I changed the format from dash_%s_%t_%r to dash_%U.

RMAN>
run {
# Hot database level 0 whole backup
allocate channel t1 type 'SBT_TAPE';
backup
incremental level 0
skip inaccessible
# recommended format
format 'dash_%U'
database
filesperset = 500;
sql 'alter system archive log current';
release channel t1;

allocate channel t1 type 'SBT_TAPE';
backup
format 'cntrl_%s_%p_%t'
current controlfile;
release channel t1;

allocate channel t1 type 'SBT_TAPE';
backup
format 'arch_%s_%p_%t'
#DELETE COPY OF ARCHIVELOG ALL COMPLETED BEFORE 'SYSDATE-1';
#format 'arch_%s_%p_%t'
archivelog all;
delete obsolete recovery window of 1 days;
crosscheck archivelog all;
resync catalog;
release channel t1;
}

allocated channel: t1
channel t1: sid=285 instance=dashgp1 devtype=SBT_TAPE
channel t1: VERITAS NetBackup for Oracle - Release 5.1 (2004122520)

Starting backup at 23-APR-08
channel t1: starting incremental level 0 datafile backupset
channel t1: specifying datafile(s) in backupset
input datafile fno=00002 name=+ORCL_DATA/dashgp/undotbs01.dbf
input datafile fno=00008 name=+ORCL_DATA/dashgp/tools01.dbf
input datafile fno=00010 name=+ORCL_DATA/dashgp/lrn_data.dbf
input datafile fno=00011 name=+ORCL_DATA/dashgp/lrn_indx.dbf
input datafile fno=00014 name=+ORCL_DATA/dashgp/gis_data01.dbf
input datafile fno=00001 name=+ORCL_DATA/dashgp/system01.dbf
input datafile fno=00003 name=+ORCL_DATA/dashgp/sysaux01.dbf
input datafile fno=00005 name=+ORCL_DATA/dashgp/undotbs02.dbf
input datafile fno=00012 name=+ORCL_DATA/dashgp/cdc_data01.dbf
input datafile fno=00013 name=+ORCL_DATA/dashgp/dash_etl_data01.dbf
input datafile fno=00004 name=+ORCL_DATA/dashgp/users01.dbf
input datafile fno=00007 name=+ORCL_DATA/dashgp/indx01.dbf
input datafile fno=00006 name=+ORCL_DATA/dashgp/drsys01.dbf
input datafile fno=00009 name=+ORCL_DATA/dashgp/xdb02.dbf
channel t1: starting piece 1 at 23-APR-08
released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on t1 channel at 04/23/2008 10:45:36
ORA-19506: failed to create sequential file, name="dash_f9jehiu1_1_1", parms=""
ORA-27028: skgfqcre: sbtbackup returned error
ORA-19511: Error received from media manager layer, error text:
VxBSACreateObject: Failed with error:
Server Status: the specified client does not exist in an active policy within the configuration database
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #316084 is a reply to message #315272] Wed, 23 April 2008 12:59 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Thank you ebrian for all your help. It has been a life saver!!! May thanks for a mid-level DBA.

I have another database, which has always been 10g and now i am trying to back it up using the new catalog. It is registered in the catalog. But when i try to back it up, it give me the following error. I changed the format from dash_%s_%t_%r to dash_%U.

RMAN>
run {
# Hot database level 0 whole backup
allocate channel t1 type 'SBT_TAPE';
backup
incremental level 0
skip inaccessible
# recommended format
format 'dash_%U'
database
filesperset = 500;
sql 'alter system archive log current';
release channel t1;

allocate channel t1 type 'SBT_TAPE';
backup
format 'cntrl_%s_%p_%t'
current controlfile;
release channel t1;

allocate channel t1 type 'SBT_TAPE';
backup
format 'arch_%s_%p_%t'
#DELETE COPY OF ARCHIVELOG ALL COMPLETED BEFORE 'SYSDATE-1';
#format 'arch_%s_%p_%t'
archivelog all;
delete obsolete recovery window of 1 days;
crosscheck archivelog all;
resync catalog;
release channel t1;
}

allocated channel: t1
channel t1: sid=285 instance=dashgp1 devtype=SBT_TAPE
channel t1: VERITAS NetBackup for Oracle - Release 5.1 (2004122520)

Starting backup at 23-APR-08
channel t1: starting incremental level 0 datafile backupset
channel t1: specifying datafile(s) in backupset
input datafile fno=00002 name=+ORCL_DATA/dashgp/undotbs01.dbf
input datafile fno=00008 name=+ORCL_DATA/dashgp/tools01.dbf
input datafile fno=00010 name=+ORCL_DATA/dashgp/lrn_data.dbf
input datafile fno=00011 name=+ORCL_DATA/dashgp/lrn_indx.dbf
input datafile fno=00014 name=+ORCL_DATA/dashgp/gis_data01.dbf
input datafile fno=00001 name=+ORCL_DATA/dashgp/system01.dbf
input datafile fno=00003 name=+ORCL_DATA/dashgp/sysaux01.dbf
input datafile fno=00005 name=+ORCL_DATA/dashgp/undotbs02.dbf
input datafile fno=00012 name=+ORCL_DATA/dashgp/cdc_data01.dbf
input datafile fno=00013 name=+ORCL_DATA/dashgp/dash_etl_data01.dbf
input datafile fno=00004 name=+ORCL_DATA/dashgp/users01.dbf
input datafile fno=00007 name=+ORCL_DATA/dashgp/indx01.dbf
input datafile fno=00006 name=+ORCL_DATA/dashgp/drsys01.dbf
input datafile fno=00009 name=+ORCL_DATA/dashgp/xdb02.dbf
channel t1: starting piece 1 at 23-APR-08
released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on t1 channel at 04/23/2008 10:45:36
ORA-19506: failed to create sequential file, name="dash_f9jehiu1_1_1", parms=""
ORA-27028: skgfqcre: sbtbackup returned error
ORA-19511: Error received from media manager layer, error text:
VxBSACreateObject: Failed with error:
Server Status: the specified client does not exist in an active policy within the configuration database
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #316096 is a reply to message #316084] Wed, 23 April 2008 14:26 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
This would seem to be MML related. Do you have a policy created for this node in the NetBackup master server?
Re: RMAN BACKUP FAILING AFTER UPGRADE FROM 9i TO 10g [message #316117 is a reply to message #315272] Wed, 23 April 2008 16:17 Go to previous message
geeklol
Messages: 59
Registered: March 2005
Member
Thank you ebrian. that worked!!!
Previous Topic: PARALLEL in Import/Export pump
Next Topic: steps to create RMAN
Goto Forum:
  


Current Time: Thu Dec 08 04:25:14 CST 2016

Total time taken to generate the page: 0.13013 seconds