Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » Forms crashes (FRM-92101) during Load Performance Testing (Oracle Application Server 10g 10.1.2.0.2, Microsoft Windows Server 2003 64bit Enterprise Edition)
Forms crashes (FRM-92101) during Load Performance Testing [message #314956] Fri, 18 April 2008 06:42 Go to next message
shahmayur
Messages: 22
Registered: November 2007
Location: London, UK
Junior Member
Hiya

We have been doing Load Performance Testing using testing tool QALoad on our Forms 10g application. After about 56 virtual users(sessions) have logged-in into our application, if a new user tries to log-in into our application, the Forms crashes. As soon as we encounter the FRM-92101 error, no more new forms session are able to start.

The Load Testing software start up each process very quickly, about every 10 seconds.

The very first form that appears is the login form of our application. So before the login screen appears, we get FRM-92101 error message.

However, those users who have already logged-in into our application, they are able to carry on their tasks.

I have checked the status on Application Server through Oracle Enterprise Manager Console. The OC4J Instance is up and running. Also, server's configuration is pretty good. It is running on 2 CPUs (AMD Opteron 3GHz) and has 32GB of memory. The memory used by those 56 sessions is less than 3GB.

The Applicatin Server is running on a Microsoft Windows Server 2003 64bit Enterprise Edition.

Any help will be much appreciated.

Cheers
Mayur
Re: Forms crashes (FRM-92101) during Load Performance Testing [message #315054 is a reply to message #314956] Fri, 18 April 2008 14:17 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
Quote:
http://forums.oracle.com/forums/thread.jspa?threadID=339852
Re: Forms crashes (FRM-92101) during Load Performance Testing [message #315657 is a reply to message #314956] Tue, 22 April 2008 06:01 Go to previous message
shahmayur
Messages: 22
Registered: November 2007
Location: London, UK
Junior Member
The above issue has been fixed now. I found its solution from Metalink.

Here's briefly what I did:

I changed the value of memory in the following registry key
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\SubSystems

Now here select the Windows value. From the Edit menu, choose String. Increase the SharedSection parameter. SharedSection specifies the system and desktop heaps using the following format:

SharedSection=xxxx,yyyy,zzzz

The default values are 1024,3072,512

In my case the values were 1024, 20480, 768

I increased the value of Non-IO Desktop Heapsize from 768 to 5112, re-booted the server and it worked !!

Now the number of virtual users connected to our application has gone up from 56 to 131. Our testing team is gradually ramping up the number of users. So it remains to be seen how many number of users can be logged in before the Forms again crashes.

The full details of this solution can be found on Metalink. The note no. is 187455.1

Cheers
Mayur
Previous Topic: Oracle Enterprise Manager 10g Application Server Control
Next Topic: Implementing Session Manager - Possibility/ Implications ?
Goto Forum:
  


Current Time: Wed Jul 23 01:22:00 CDT 2014

Total time taken to generate the page: 0.10310 seconds