Home » Server Options » Streams & AQ » MGW agent can't start (Oracle AQ 10.2)
MGW agent can't start [message #314098] Tue, 15 April 2008 15:31 Go to next message
kanetkark
Messages: 2
Registered: April 2008
Junior Member
Hello, I'm trying to use oracle messaging gateway but i cannot run the mgwagent.
I'm using oracle 10G R2 with linux 64. I did follow the oracle documentation filling my listener.ora, tnsnames.ora and mgw.ora. But I obtain the following error looking at my mgw_gateway view : ora-28595 : Extproc agent : invalid dll path.

Has anyone experienced the same problem?
Below is my listener.ora details. So will it work at all on Linux 64-bit with any changes to listener.ora?

################
# Filename......: listener.ora
# Name..........: Oracle listener definitions file for Guidant
# Date..........: 04-Feb-2002
# : 08-Feb-2005 10g Modifications
################
#

#
# Define "where" to listen
# ~~~~~~~~~~~~~~~~~~~~~~~~~~
LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = AVAQD))
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
(ADDRESS = (PROTOCOL = TCP)(Host = ADAQ03)(Port = 1521))
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
)
)
)

#
# Pre-Defined Services
# ~~~~~~~~~~~~~~~~~~~~~~~~~~
SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SDU = 1460)
(SID_NAME = AVAQD)
(GLOBAL_DBNAME = AVAQD)
(SERVICE_NAME = AVAQD.world)
(ORACLE_HOME = /ofa/product/10.2.0/DB)
)
(SID_DESC =
(SID_NAME = mgwextproc)
(ENVS = " LD_LIBRARY_PATH=/ofa/product/10.2.0/DB/jre/1.4.2/lib/i386:/ofa/product/10.2.0/DB/jre/1.4.2/lib/i386/server:/ofa/product/10.2.0/DB/lib ")
(ORACLE_HOME = /ofa/product/10.2.0/DB)
(PROGRAM = extproc)
)
(SID_DESC =
(SID_NAME = PLSExtProc)
(ORACLE_HOME = /ofa/product/10.2.0/DB)
(ENVS="EXTPROC_DLLS=/ofa/product/10.2.0/DB/lib32/av_extproc_LINUX.so")
(PROGRAM = extproc)
)
)

#
# Tracing / Logging
# ~~~~~~~~~~~~~~~~~~~~~~~~~~
TRACE_LEVEL_LISTENER = OFF

#
# Miscellaneous Parameters
# ~~~~~~~~~~~~~~~~~~~~~~~~~~
CONNECT_TIMEOUT_LISTENER = 10
STARTUP_WAIT_TIME_LISTENER = 0
SUBSCRIBE_FOR_NODE_DOWN_EVENT_LISTENER = OFF
SAVE_CONFIG_ON_STOP_LISTENER = OFF


Regards

Kiran
Re: MGW agent can't start [message #314161 is a reply to message #314098] Tue, 15 April 2008 22:15 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Quote:
EXTPROC_DLLS=/ofa/product/10.2.0/DB/lib32/av_extproc_LINUX.so


Check this path.
Re: MGW agent can't start [message #314414 is a reply to message #314098] Wed, 16 April 2008 11:29 Go to previous message
kanetkark
Messages: 2
Registered: April 2008
Junior Member
I already tried that by removing it once and then adding back in. I still get the same error.

Does AQ and messaging gateway work with 64 bit Linux?

Regards

Kiran
Previous Topic: doubt regarding using variable in deq_condition
Next Topic: Dequeue a message from queue after a certain time
Goto Forum:
  


Current Time: Tue Jul 29 20:44:10 CDT 2014

Total time taken to generate the page: 0.04966 seconds