Home » RDBMS Server » Enterprise Manager » enterprise manager installation and configuration (Oracle 10g 10.2.0.1 on Linux 32 bit)
enterprise manager installation and configuration [message #313981] Tue, 15 April 2008 06:53 Go to next message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
Hi,
I want to install Enterprise manager as i have recover my database from RMAN, but i do not have actual folder used in Enterprise manager. Repository is created but there is a error in bottom

oracle@TEST:/u01/app/oracle/product/10.2.0/db_1/bin$ ./emca -config dbcontrol db -repos create

STARTED EMCA at 15-Apr-2008 13:10:35
EM Configuration Assistant, Version 10.2.0.1.0 Production
Copyright (c) 2003, 2005, Oracle. All rights reserved.

Enter the following information:
Database SID: test
Listener port number: 1521
Password for SYS user:
Password for DBSNMP user:
Password for SYSMAN user:
Email address for notifications (optional):
Outgoing Mail (SMTP) server for notifications (optional):
-----------------------------------------------------------------

You have specified the following settings

Database ORACLE_HOME ................ /u01/app/oracle/product/10.2.0/db_1

Database hostname ................ localhost
Listener port number ................ 1521
Database SID ................ test
Email address for notifications ...............
Outgoing Mail (SMTP) server for notifications ...............

-----------------------------------------------------------------
Do you wish to continue? [yes(Y)/no(N)]: yes
15-Apr-2008 13:10:54 oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at /u01/app/oracle/product/10.2.0/db_1/cfgt oollogs/emca/test/emca_2008-04-15_01-10-35-PM.log.
15-Apr-2008 13:10:56 oracle.sysman.emcp.EMReposConfig createRepository
INFO: Creating the EM repository (this may take a while) ...
15-Apr-2008 13:18:37 oracle.sysman.emcp.EMReposConfig invoke
INFO: Repository successfully created
Exception in thread "main" java.lang.NoClassDefFoundError: oracle/sysman/emSDK/conf/ConfigManager
at oracle.sysman.emcp.EMDBCConfig.updateEmomsProps(EMDBCConfig.java:852)
at oracle.sysman.emcp.EMDBCConfig.performConfiguration(EMDBCConfig.java:367)
at oracle.sysman.emcp.EMDBCConfig.invoke(EMDBCConfig.java:154)
at oracle.sysman.emcp.EMDBCConfig.invoke(EMDBCConfig.java:128)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:143)
at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:479)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1123)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:463)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:412)

oracle@TEST:/u01/app/oracle/product/10.2.0/db_1/bin$./emctl status dbconsole
TZ set to GB-Eire
EM Configuration issue. /u01/app/oracle/product/10.2.0/db_1/localhost_test not found.
Re: enterprise manager installation and configuration [message #313982 is a reply to message #313981] Tue, 15 April 2008 06:55 Go to previous messageGo to next message
Michel Cadot
Messages: 64139
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
It is useless to post a question in a wrong forum in order to get more answer.
Moved.

Regards
Michel
Re: enterprise manager installation and configuration [message #314152 is a reply to message #313981] Tue, 15 April 2008 22:08 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Check the contents of /u01/app/oracle/product/10.2.0/db_1/cfgt oollogs/emca/test/emca_2008-04-15_01-10-35-PM.log

It will show what you need to do. If you want direct solution you can follow,

http://arjudba.blogspot.com/2008/04/stack-of-problems-while-creating.html
Re: enterprise manager installation and configuration [message #314258 is a reply to message #314152] Wed, 16 April 2008 03:41 Go to previous messageGo to next message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
Following are lines from log file.

CONFIG: Could not find or correctly parse file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/jms.xml in searching for tag jms-server with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/jms.xml (No such file or directory)

CONFIG: Could not find or correctly parse
file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/rmi.xml in searching for tag rmi-server with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/rmi.xml (No such file or directory)

CONFIG: Could not find or correctly parse
file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/http-web-site.xml in searching for tag web-site with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/http-web-site.xml (No such file or directory)

Though all these files exists and have port, i copied the whole folder of OC4J_DBConsole_localhost_test/config from database which have EM running fine.

[Updated on: Wed, 16 April 2008 04:03]

Report message to a moderator

Re: enterprise manager installation and configuration [message #314260 is a reply to message #313981] Wed, 16 April 2008 03:50 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Why first few lines instead of last few lines?

Did you followed my suggestion that is in my blog?
Re: enterprise manager installation and configuration [message #314268 is a reply to message #314260] Wed, 16 April 2008 04:36 Go to previous messageGo to next message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
Following are error from log file.

CONFIG: Could not find or correctly parse file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/jms.xml in searching for tag jms-server with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/jms.xml (No such file or directory)

CONFIG: Could not find or correctly parse
file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/rmi.xml in searching for tag rmi-server with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/rmi.xml (No such file or directory)

CONFIG: Could not find or correctly parse
file /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/http-web-site.xml in searching for tag web-site with attribute port

java.io.FileNotFoundException: /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_localhost_test/config/http-web-site.xml (No such file or directory)

Though all these files exists and have port, i copied the whole folder of OC4J_DBConsole_localhost_test/config from database which have EM running fine.

I rename the oc4j folder and drop the repository and then recreate the control object and reopository,
Same problem repository successfully created but configuration file is not created and folder oc4j is not created
Re: enterprise manager installation and configuration [message #314307 is a reply to message #314268] Wed, 16 April 2008 05:50 Go to previous messageGo to next message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
Yes Arju, do you have any idea that configuration script is not creating required folder
Re: enterprise manager installation and configuration [message #314312 is a reply to message #313981] Wed, 16 April 2008 05:52 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Analysis properly of log file.

When you don't have permission in OS level it will fail to create folder.
Re: enterprise manager installation and configuration [message #314374 is a reply to message #314312] Wed, 16 April 2008 08:33 Go to previous messageGo to next message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
There is no way to create and configure EM Database Control from scratch after deleting all folders like localhost_SID,<ORACLE_HOME/sysman>,oc4j
Re: enterprise manager installation and configuration [message #314381 is a reply to message #313981] Wed, 16 April 2008 08:48 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
There is no way to teach a pig how to fly.
There are many thing that are not possible; but for some we know how to work around these impediments.
Re: enterprise manager installation and configuration [message #314389 is a reply to message #314381] Wed, 16 April 2008 09:37 Go to previous message
MIFI
Messages: 256
Registered: February 2008
Location: U.K.
Senior Member
Thank you for your help.
Previous Topic: Running EMCA Fails To Accept the DBSNMP Password
Next Topic: enterprise manager
Goto Forum:
  


Current Time: Thu Dec 08 08:17:40 CST 2016

Total time taken to generate the page: 0.28493 seconds