Home » Infrastructure » Linux » setting appropriate nls_lang (10.2.0.1,RHEL 4)
setting appropriate nls_lang [message #312507] Wed, 09 April 2008 01:37 Go to next message
varu123
Messages: 754
Registered: October 2007
Senior Member

10.2.0.1,RHEL 4
I craeted a database with AL32UTF8 character sett and AL16UTF16 national character set.
According to
http://www.oracle.com/technology/tech/globalization/htdocs/nls_lang%20faq.htm#_Toc110410565
I set
LC_ALL=utf-8
nls_lang=HINDI_INDIA.UTF8
I imported table containing hindi data.
import done in UTF8 character set and AL16UTF16 NCHAR character set
import server uses AL32UTF8 character set (possible charset conversion)
export client uses US7ASCII character set (possible charset conversion)
export server uses UTF8 NCHAR character set (possible ncharset conversion)

I can login the database but when i query table containing hindi data
Its showing
small rectangular boxes as the rows.
I want to display hindi data in sqlplus in linux.

Re: setting appropriate nls_lang [message #312515 is a reply to message #312507] Wed, 09 April 2008 02:06 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Does SQL*Plus handle hindi characters?
This is the first question.
Select with spool in a file and open the file with a tool you know it supports hindi characters and see.

Regards
Michel
Re: setting appropriate nls_lang [message #312518 is a reply to message #312507] Wed, 09 April 2008 02:17 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
I spooled teh file and saw in vi editor,it is showing in hindi.

As whether sqlplus supports Hindi,from the link i posted it is written
Quote:
Is iSQL*Plus the only UTF8/Unicode enabled client we support?

On Windows OS, yes, On Unix OS's, no. All the database utilties, including Import, Export, SQL*Loader, SQL*Plus, can act as a UTF-8 client if the OS locale is UTF-8 (e.g., en_US.UTF-8 on Linux) and NLS_LANG character set is set to UTF8 or AL32UTF8.

[Updated on: Wed, 09 April 2008 02:17]

Report message to a moderator

Re: setting appropriate nls_lang [message #312519 is a reply to message #312507] Wed, 09 April 2008 02:22 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
Ok, if use GUI sqlplus,it is showing in hindi.
But if use Command line sqlplus,it is showing empty boxes.
Re: setting appropriate nls_lang [message #312531 is a reply to message #312519] Wed, 09 April 2008 02:49 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
1/ Does your DOS code page support hindi?
2a/ If yes, then sqlplus line mode does not support it.
2b/ If no, change it and retry.

Regards
Michel
Re: setting appropriate nls_lang [message #312546 is a reply to message #312507] Wed, 09 April 2008 03:58 Go to previous messageGo to next message
varu123
Messages: 754
Registered: October 2007
Senior Member
Unable to find how to verify and chnage code points in linux. Sad


Re: setting appropriate nls_lang [message #312558 is a reply to message #312546] Wed, 09 April 2008 04:34 Go to previous message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Sorry don't know either.

Move it to Linux forum.

Regards
Michel
Previous Topic: Function Keys not visible to Linux
Next Topic: Connecting Linux to oracle
Goto Forum:
  


Current Time: Sat Dec 10 01:31:59 CST 2016

Total time taken to generate the page: 0.29295 seconds