Home » RDBMS Server » Server Administration » ORA-4031.....while starting up database (oracle 9.2.0.4 on solaris 5.9)
ORA-4031.....while starting up database [message #311271] Thu, 03 April 2008 20:21 Go to next message
harry07
Messages: 61
Registered: June 2007
Location: now york
Member
When I am trying to mount my database it is giving me following error:-

ORA-04031: unable to allocate 41032 bytes of shared memory ("large pool","unknown object","large pool","PX msg pool")


I have tried flushing the shared pool, but didnt help.

The shared pool size is pretty big around 1 Gb.
Re: ORA-4031.....while starting up database [message #311303 is a reply to message #311271] Fri, 04 April 2008 00:43 Go to previous messageGo to next message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You have to enlarge LARGE POOL not SHARED POOL, as pointed in the message.

Regards
Michel
Re: ORA-4031.....while starting up database [message #311498 is a reply to message #311303] Fri, 04 April 2008 11:36 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Check for pfile/spfile may be there more than one and which have not enough memory!!!As mentioned by Michel!
Re: ORA-4031.....while starting up database [message #311775 is a reply to message #311271] Sun, 06 April 2008 14:52 Go to previous messageGo to next message
harry07
Messages: 61
Registered: June 2007
Location: now york
Member
Hi

I have checked the init.ora with the production instance, and all paramters match each other.
Large pool size = 9M & it is working fine on production.

Is there any other potential reason for this problem .
Re: ORA-4031.....while starting up database [message #311776 is a reply to message #311775] Sun, 06 April 2008 14:53 Go to previous messageGo to next message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This is the problem. Full stop.

Regards
Michel
Re: ORA-4031.....while starting up database [message #311777 is a reply to message #311271] Sun, 06 April 2008 14:56 Go to previous messageGo to next message
harry07
Messages: 61
Registered: June 2007
Location: now york
Member
i know its the problem.........so any idea to resolve this.
Re: ORA-4031.....while starting up database [message #311778 is a reply to message #311777] Sun, 06 April 2008 15:05 Go to previous messageGo to next message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Michel Cadot wrote on Fri, 04 April 2008 07:43
You have to enlarge LARGE POOL not SHARED POOL, as pointed in the message.

Regards
Michel


Re: ORA-4031.....while starting up database [message #311779 is a reply to message #311271] Sun, 06 April 2008 15:11 Go to previous messageGo to next message
harry07
Messages: 61
Registered: June 2007
Location: now york
Member
I have increased the large pool, but that doesnt help ........

Re: ORA-4031.....while starting up database [message #311780 is a reply to message #311779] Sun, 06 April 2008 15:21 Go to previous messageGo to next message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Enlarge more or decrease parallelism.

Regards
Michel
Re: ORA-4031.....while starting up database [message #311781 is a reply to message #311271] Sun, 06 April 2008 15:38 Go to previous message
harry07
Messages: 61
Registered: June 2007
Location: now york
Member
Thanks,........it helped.
Previous Topic: Oracle Express - Cannot connect to the service
Next Topic: ORA-27091 & ORA-27037
Goto Forum:
  


Current Time: Fri Dec 09 15:54:00 CST 2016

Total time taken to generate the page: 0.14133 seconds