Home » Developer & Programmer » Reports & Discoverer » Posting Date (disc 10.1.2)
Posting Date [message #311214] Thu, 03 April 2008 13:16 Go to next message
aarti81
Messages: 235
Registered: December 2007
Location: USA
Senior Member
Hi
In my report , i have the following fields

POSTED_DATE BEGIN_DATE END_DATE
The conditions are BEGIN_DATE> POST_DATE and END_DATE=BEG_DATE+18. Upto this part it went fine, but now i have to get the recent posted date from the total list and apply the above condition.My question is how to get the recent POSTED_DATE, pls any help is grtly appreciated.

Thanks
Re: Posting Date [message #311310 is a reply to message #311214] Fri, 04 April 2008 01:07 Go to previous messageGo to next message
skooman
Messages: 912
Registered: March 2005
Location: Netherlands
Senior Member
Sorry, I don't understand what you mean. Could you please provide us with a brief example of the data you have and what the desired output should look like?
Re: Posting Date [message #311312 is a reply to message #311310] Fri, 04 April 2008 01:15 Go to previous messageGo to next message
Littlefoot
Messages: 20895
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
It's me again, commenting Discoverer questions ... probably very far from the point, but:
Quote:
i have to get the recent posted date

Isn't that something like
SELECT MAX(posted_date) 
FROM some_table
WHERE some_condition(s)
Re: Posting Date [message #311406 is a reply to message #311312] Fri, 04 April 2008 07:12 Go to previous messageGo to next message
skooman
Messages: 912
Registered: March 2005
Location: Netherlands
Senior Member
Aha. If that's the case, then use subqueries in Discoverer (the funtionality is called something like related workbook, used in conditions - you should be able to find it in the manual).
Re: Posting Date [message #311433 is a reply to message #311406] Fri, 04 April 2008 08:39 Go to previous messageGo to next message
aarti81
Messages: 235
Registered: December 2007
Location: USA
Senior Member
I tried all the above, but for some reason i'm not getting the expected results. in the discoverer admin i created a custom folder with the SQL in it and when i joined it to the other folder its giving me the ORA01468 ERROR as the other folder is already joined to a 3rd folder.Any advices?
Re: Posting Date [message #311441 is a reply to message #311433] Fri, 04 April 2008 08:58 Go to previous message
skooman
Messages: 912
Registered: March 2005
Location: Netherlands
Senior Member
Then either you have defined the master-detail relationships in Discoverer the wrong way around, or your datamodel is very badly designed. Please check the involved master-details first.
Previous Topic: Losing records
Next Topic: Rdf i want to send through mail.
Goto Forum:
  


Current Time: Mon Dec 05 21:11:24 CST 2016

Total time taken to generate the page: 0.13364 seconds