Home » RDBMS Server » Enterprise Manager » How to start OEM (Oracle 11.2.0.3.0 , RHL 5.7)
How to start OEM [message #576832] Fri, 08 February 2013 07:40 Go to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Hi,

Could you tell me how to start OEM 12c agent on Linux server ?

Note:
Its a RAC server .

Regards,
Jack
Re: How to start OEM [message #576833 is a reply to message #576832] Fri, 08 February 2013 07:47 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
emctl start agent
Re: How to start OEM [message #576835 is a reply to message #576833] Fri, 08 February 2013 08:06 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
John,

Thank you for the answer.

Can you also tell me
1.From which path the command has to be executed and
2.Does it require DB or Instance downtime during starting OEM?

Regards,
Jack
Re: How to start OEM [message #576836 is a reply to message #576835] Fri, 08 February 2013 08:09 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
Do a few tests, and all will become clear.
Re: How to start OEM [message #576837 is a reply to message #576836] Fri, 08 February 2013 08:34 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
I found the agent path.It is under ORACLE_HOME/bin

Thank you John
Re: How to start OEM [message #576841 is a reply to message #576837] Fri, 08 February 2013 09:11 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Hi,

When i check the status of agent it gives permission denied.

[oracle@ORCL1 bin]$ whoami
oracle
[oracle@ORCL1 bin]$ ls -alrt emctl
-rwxr--r-- 1 grid oinstall 15511 May 23 2012 emctl

[oracle@ORCL1 bin]$ pwd
/u01/app/grid/product/11.2.0/bin
[oracle@RAC1 bin]$ emctl status agent
-bash: /u01/app/grid/product/11.2.0/bin/emctl: Permission denied

Can you tell me what permission i need to have to execute emctl command?

Thank you
Re: How to start OEM [message #576843 is a reply to message #576841] Fri, 08 February 2013 09:19 Go to previous messageGo to next message
BlackSwan
Messages: 22911
Registered: January 2009
Senior Member
>Can you tell me what permission i need to have to execute emctl command?

OS user "grid" owns the file so log onto the OS as that OS user.
Re: How to start OEM [message #576846 is a reply to message #576843] Fri, 08 February 2013 09:29 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Swan,

I logged in as Grid user and executed emctl status agent but this time it was different output.

[grid@ORCL1 ~]$ whoami
grid
[grid@ORCL1 ~]$ cd $OMS_HOME
[grid@ORCL1 ~]$ pwd
/home/grid
[grid@ORCl1 ~]$ emctl status agent
Can't locate CompEM.pm in @INC

Need your help.

Thank you
Re: ORA-00904: "POLTYP": invalid identifier [message #576874 is a reply to message #576832] Sat, 09 February 2013 03:33 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Paul,

To post your question , one has to open a new thread and post your question.

Seniors,

Nobody has answer to my questions?


[EDITED by LF: after I split an unrelated message from this topic, the first sentence in this message became meaningless]

[Updated on: Sat, 09 February 2013 13:33] by Moderator

Report message to a moderator

Re: ORA-00904: "POLTYP": invalid identifier [message #576875 is a reply to message #576874] Sat, 09 February 2013 03:44 Go to previous messageGo to next message
Michel Cadot
Messages: 59427
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Maybe we are tired of your questions when you even don't care to follow the guide.

Regards
Michel
Re: ORA-00904: "POLTYP": invalid identifier [message #576876 is a reply to message #576875] Sat, 09 February 2013 03:47 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Michel,

Can you answer my question now ?
Re: How to start OEM [message #576877 is a reply to message #576837] Sat, 09 February 2013 04:01 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
You have found that there is an emctl in the database home, which manages the DB Console. There is an emctl in the OMS home, that manages the Management Server. Don't you think that there might also be an emctl in the Agent home?
Please, Jack, use your initiative! Or read the docs.
Re: How to start OEM [message #576878 is a reply to message #576877] Sat, 09 February 2013 04:13 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
John,
I tried this time in agent home but same permission denied.

[oracle@RAC1 ~]$ cd $OMS_AGENT
[oracle@RAC1 ~]$ pwd
/home/oracle
[oracle@RAC1 ~]$ emctl status agent
-bash: /u01/app/grid/product/11.2.0/bin/emctl: Permission denied
[oracle@RAC1 ~]$
[oracle@RAC1 ~]$ whoami
oracle

Re: How to start OEM [message #576880 is a reply to message #576878] Sat, 09 February 2013 05:04 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
Thank, man! Does changing directory change your search path? Which emctl are you running? You know about setting the environment variables ORACLE_HOME and PATH. Do it.
Re: How to start OEM [message #576881 is a reply to message #576880] Sat, 09 February 2013 06:02 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
1.Which emctl are you running?

emctl 12c

2.You know about setting the environment variables ORACLE_HOME and PATH

I have set env variables using .oraenv utility file.

3.Does changing directory change your search path ?
No it is same as before.

Regards,
Jack
Re: How to start OEM [message #576882 is a reply to message #576881] Sat, 09 February 2013 06:08 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
Quote:
1.Which emctl are you running?

emctl 12c

2.You know about setting the environment variables ORACLE_HOME and PATH

I have set env variables using .oraenv utility file.

3.Does changing directory change your search path ?
No it is same as before.

Regards,
Jack

1. Jack, there will be three copies of emctl, one in each home. When I ask "which emctl are you running" the answer is not "12c".
2. So what did you set those variables to?
3. Exactly. That is why you are still running the wrong emctl.

Seriously, you need to ask yourself if you have the prerequisite background knowledge to understand the Cloud Control environment. Perhaps you should start by describing your understanding of the Cloud Control architecture. Once you have that straight, you will be able to work out these trvial operational questions yourself.
Re: How to start OEM [message #576885 is a reply to message #576882] Sat, 09 February 2013 06:52 Go to previous messageGo to next message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
John,

Here is the answers below.

1. Jack, there will be three copies of emctl, one in each home. When I ask "which emctl are you running" the answer is not "12c".

I hope you are refering to OMS_AGENT,ORACLE_HOME and OMS_HOME. i check all the 3 home and did not found emctl file in the directory.

[oracle@rac1 ~]$ cd $OMS_AGENT
[oracle@rac1 ~]$ pwd
/home/oracle
[oracle@rac1 ~]$ ls -alrt emctl
ls: emctl: No such file or directory
[oracle@rac1 ~]$
[oracle@rac1 ~]$ cd $ORACLE_HOME
[oracle@rac1 DB1]$ pwd
/u01/app/oracle/product/11.2.0/DB1
[oracle@rac1 DB1]$
[oracle@rac1 DB1]$ ls -alrt emctl
ls: emctl: No such file or directory


When I ask "which emctl are you running" the answer is not "12c".

Can you tell me what answer i should give for this ?

2. So what did you set those variables to?

i set those variables like

[oracle@rac1 ~]$ . oraenv
ORACLE_SID = [FS0001Q2] ?
ORACLE_HOME = [/home/oracle] ? /u01/app/oracle/product/11.2.0/DB1
The Oracle base has been set to /u01/app/oracle

3. Exactly. That is why you are still running the wrong emctl.

Can you tell me what i need to do here ?
Re: How to start OEM [message #576887 is a reply to message #576885] Sat, 09 February 2013 07:14 Go to previous messageGo to next message
John Watson
Messages: 4693
Registered: January 2010
Location: Global Village
Senior Member
For the last time: you have to think.

You did this,
[oracle@rac1 ~]$ cd $OMS_AGENT
[oracle@rac1 ~]$ pwd
/home/oracle
[oracle@rac1 ~]$ ls -alrt emctl
ls: emctl: No such file or directory
[oracle@rac1 ~]$
does the variable $OMS_AGENT even exist? If it does exist, do you believe that /home/oracle is a sensible value for it?
Then you set your ORACLE_HOME to the database home. Do you think that is correct when you want to manage the OMS Agent?

I cannot assist someone who, it seems to me, lacks the pre-requisite knowledge needed to manage the Cloud Control environment. This is not a toy: you cannot simply install it and use it. You have to read the docs, you have to understand the components.

Perhgaps someone else will assist - it is clear that I can't.

Goodbye, and good. luck.
Re: How to start OEM [message #576900 is a reply to message #576887] Sat, 09 February 2013 22:13 Go to previous message
Jack14
Messages: 497
Registered: December 2011
Location: INDIA
Senior Member
Thank you for assisting me so far in this thread.
Previous Topic: dbconsole connecting problem
Next Topic: Don't get any heartbeat
Goto Forum:
  


Current Time: Sat Oct 25 07:20:55 CDT 2014

Total time taken to generate the page: 0.14678 seconds